Какие пакеты/библиотеки, которые я должен установить перед компиляцией питона из исходников?

Время от времени мне нужно, чтобы установить новый для Ubuntu (я использовал его как для настольного компьютера и сервера) и я всегда забываю, пару библиотек надо было установить перед компиляцией, а значит, придется перекомпилировать, и это начинает раздражать.

Поэтому сейчас я хочу составить полный список всех библиотечных пакетов для установки Перед тем, как компилировать Python (и желательно как необязательно они).

Это список я составил с помощью ниже и покопавшись в setup.py. Оно полное для Ubuntu 10.04 и 11.04 по крайней мере:

наращивание основного (очевидно)
сайт libz-Дэв (также довольно общие и существенные)
libreadline-dev и (или питон подсказка хрень)
libncursesw5-dev и
libssl-dev и
libgdbm-Дэв
libsqlite3-dev и
libbz2-dev и

Для Python 3.2 и более поздних версий:

liblzma-Дэв

Еще дополнительно:

ТК-Дэв
последней-Дэв

В Ubuntu нет пакетов для v1.8.5 из Беркли базе, ни (по понятным причинам) Солнце звукового оборудования, поэтому bsddb185 и sunaudiodev модули все равно не будут построены на Ubuntu, но все остальные модули строятся с учетом выше установленных пакетов.

Обновление

Есть в Ubuntu 14.04 даже больше патчей, необходимых для Python 2.6, и 2.7 и т. д. Я бы рекомендовал вместо проверки pyenv. Он содержит скрипт на Python-построить (находится в плагины/питон-строить/бин). С его помощью вы можете установить произвольные версий Python, как это:

$ ./питон-строить 2.7.8 /опт/python27

Где 2.7.8 версия и /opt/python27-это путь он будет установлен. Pyenv будет скачать версию Python, применить необходимые патчи и настроить; совершать; сделать установку для вас.

КОНЕЦ ОБНОВЛЕНИЯ

В Python 2.5 и Python 2.6 также должен иметь LDFLAGS установить на Ubuntu 11.04 и позже, чтобы справиться с новой Multi-свода макета:

экспорт LDFLAGS="-л в/usr/lib в/$(с dpkg-архитектура -qDEB_HOST_MULTIARCH)"

Для Python 2.6, 2.7 и 3.0 вы также должны явно включить SSL после запуска ./настроить скрипт и перед запуском сделать. В модули/установки есть строки такой:

#Протокол SSL=/usr/местные/протокол SSL
#_ssl _ssl.с \
# -DUSE_SSL -я$(с SSL)/включить-я$(с SSL)/входят/в OpenSSL \
# -Л$(с SSL)/Либ -lssl -lcrypto

Раскомментируйте эти строки и изменить протокол SSL переменной в/usr:

Протокол SSL=/usr и
_ssl _ssl.с \
 -DUSE_SSL -я$(с SSL)/включить-я$(с SSL)/входят/в OpenSSL \
 -Л$(с SSL)/Либ -lssl -lcrypto

Python 2.6 и 3.0 тоже нужны модули/_ssl.З. изменен, чтобы использоваться с OpenSSL 1.0, который используется в Ubuntu 11.10. Приблизительно в строке 300 Вы найдете это:

 еще если (proto_version == PY_SSL_VERSION_SSL3)
 собственн->СТХ = SSL_CTX_new(SSLv3_method()); /* настройка контекста */
 еще если (proto_version == PY_SSL_VERSION_SSL2)
 собственн->СТХ = SSL_CTX_new(SSLv2_method()); /* настройка контекста */
 еще если (proto_version == PY_SSL_VERSION_SSL23)
 собственн->СТХ = SSL_CTX_new(SSLv23_method()); /* настройка контекста */

Изменить это на:

 еще если (proto_version == PY_SSL_VERSION_SSL3)
 собственн->СТХ = SSL_CTX_new(SSLv3_method()); /* настройка контекста */
#ifndef OPENSSL_NO_SSL2
 еще если (proto_version == PY_SSL_VERSION_SSL2)
 собственн->СТХ = SSL_CTX_new(SSLv2_method()); /* настройка контекста */
#за endif
 еще если (proto_version == PY_SSL_VERSION_SSL23)
 собственн->СТХ = SSL_CTX_new(SSLv23_method()); /* настройка контекста */

Это отключает поддержку SSL_v2, которая, видимо, ушла в OpenSSL1.0.

В Python 2.4 (да, я все еще есть некоторые старые проекты, которые нуждаются в 2.4) нужен этот патч setup.py:

--- setup.py 2006-10-08 19:41:25.000000000 +0200
+++ setup.py 2012-05-08 14:02:14.325174357 +0200
@@ -269,6 +269,7 @@
 lib_dirs = собственн.компилятор.library_dirs + [
 '/lib64', 'в/usr/lib64',
 '/Либ', '/УСР/Либ',
+ '/УСР/Либ/x86_64 с-Линукс-гну'
]
 inc_dirs = собственн.компилятор.include_dirs + ['в/usr/включать']
 расширению = []
@@ -496,7 +497,8 @@
 ssl_incs += krb5_h
 ssl_libs = find_library_file(самовыдвижение.компилятор, 'протокол SSL',lib_dirs,
['/usr/местные/протокол SSL/Либ',
- 'в/usr/ВНО/протокол SSL/Либ/'
+ 'в/usr/ВНО/протокол SSL/Либ/',
+ 'x86_64 с-Линукс-гну'
 ] )

 если (ssl_incs нет ни у кого и

И он должен быть скомпилирован с:

ОКР добейтесь того,="-я в/usr/lib в/x86_64 с-Линукс-гну" LDFLAGS="-л в/usr/включать/x86_64 с-Линукс-гну" ./настроить --префикс=/опт/вместо python2.4
+917
Bruno Arueira 2 дек. 2018 г., 7:12:43
28 ответов

Назад в день, там был захват. Это были сложные, несколько неудобным интерфейсом, но все было настраиваемым и, как правило, это сработало. Затем он был заброшен.

Теперь есть всевозможные инструменты, но найти один, который имеет достаточные возможности настройки (пожалуйста, позвольте мне представить командной строки хромает ... вот и все, что я прошу!) была многолетней фрустрации. Я думаю, я понимаю желание сохранить вещи простыми, но наверняка кто-то еще хочет использовать "--пресет экстрим". Рукоятка также была аккуратной системе для обработки специальных символов в названия треков (содрал любой Сигур группы или альбомы múm?) что я не видел в других инструментах.

Вот те, которые я пробовал:

  • АБВГД — больно "уй", раздражает и сложно заниматься, когда конвертер не имеет сведения, но это настраивается и в целом это лучшее из много (удивительно)
  • порознь — не можем настроить хромой вариантов, не действует в Unix-м Вт.Р.Т. параметры конфигурации (например, дорожки с ведущими слеши не является абсолютным)
  • ripperx — более настраиваемый, что позволяет "лишние" варианты хромает, запутанным пользовательского интерфейса, документации устаревшим способом
  • звук-соковыжималка — Убунту врачи предупреждают людей из-за некоторых проблем с GStreamer
  • rubyripper — попытался это и ненавидели его по причинам, которые я сейчас не могу вспомнить, да и не в репозиториях, во всяком случае
  • Банши — неадекватное варианта конфигурации, убогого в iTunes-как пользовательский интерфейс (я наверное в меньшинстве, что посмотреть), вялым и раздутой

Я не пробовала средства KDE.

Моя основная проблема что я живу в прошлом здесь? Есть некоторые удивительные Потрошитель/энкодера в репозиторий, который ловко уклоняется от поисков через синаптическую?

+997
Kate Barnett 03 февр. '09 в 4:24

Я только сейчас получил сегодня новый компьютер от друга. Я исследовал все сообщения на Google, чтобы попытаться выяснить, как сбросить пароль root, т. к. не знаю его и не могу с ним связаться. Пробовал перемонтировать, говорит мне, что он не может найти его. Попробовал в меню восстановления, конечно, я получаю ошибку, так как это только для чтения. Когда я пытался пройти через fdisk, чтобы сделать его только для чтения, он говорил что-то про проверено и т. д. чистые блоки и затем сидит там. Я не знаю, что делать в этот момент. Любая помощь будет оценили

+962
sym3tri 26 сент. 2017 г., 11:21:43

Я 2-го буду cweiske. Я использую rsync, чтобы скопировать все мои файлы в мой домашний каталог на машины установить различные версии BSD и Linux, и наоборот. Я установил его, точно так же - игнорировать определенные файлы, включать в файл "X" в папку "Y", но удалить "з" (особенно если делаешь резервную копию)

+902
btc helpindia 25 авг. 2013 г., 17:19:05

Я недавно повышен с Мэвериком, Нэтти и эта проблема появилась после обновления - ничего не случилось, пока я был в Мэверик.

Я постараюсь объяснить это как можно лучше.

На Maverick, когда я подключил/отключил внешний монитор к моему ноутбуку мне пришлось вручную включить/отключить внешний монитор от диалоговых мониторов.

Но на Нэтти, когда я подключить/отключить монитор это автоматически, а дисплей включается/выключается, без меня ему пришлось бы, что диалог мониторы и делать что угодно. Я думаю, что ОС делает некоторых избирательных внешнего дисплея порт, чтобы увидеть, если что-то подключено.

Моя проблема, когда я уже подключен внешний монитор и использую его, иногда он становится инвалидом ОС, как если бы я пошел к мониторам диалог и отключил его вручную, только я ничего не делал, смотрел кино и я не возле компьютера вообще. Я думаю, что это автоопределение функция отключает его. Кажется, что он думает, что я отключил кабель, хотя я и не. Я думаю, что VGA кабель не делает хороший контакт с контактами в ноутбуке порт VGA, так что это может быть отключение на долю секунды, но это не было бы проблемой, если бы не эта функция автоопределения.

+891
Edelweiss 4 янв. 2014 г., 17:26:14

На моем ноутбуке, работающем 10.10, всякий раз, когда я подключить флэш-накопитель Наутилус будет добавить значок на рабочем столе и откройте окно Диспетчера файлов с содержимым диска. Это не работает для меня 250 Мб Жесткий диск: значок добавляется на рабочий стол, а не окно Диспетчера файлов выскакивает. Двойной щелчок на значке просто вызывает какую-то активность на диске (на системном диске) и ничего больше. Двойным нажатием еще раз на иконку файлового менеджера в итоге открывает. Сначала я думал, что это было связано с Наутилус-элементарно, но после удаления ничего не изменилось. Как я могу даже начать отладку этого?

Обновление: предложения ниже мне стало любопытно, поэтому я "безопасно извлечь" диск, выключил его и включил его снова. На этот раз он откроет на первый двойной щелчок (не ES Проводник файловый менеджер окна пока, во всяком случае). Делаю быстрый "смонтировать" в терминале показывает мой USB-накопитель монтируется как устройство блока предохранителей. Я подозреваю, что первый неэффективными двойной клик может быть использован для загрузки/запуска все пространство пользователей штучка файловой системы.

Обновление: из того, что я вижу после загрузки на жесткий диск монтируется как только значок появится на рабочем столе, единственное, что не работает двойной щелчок в первый раз. Щелкните правой кнопкой мыши диск и выбрав "открыть" всегда работает в первый раз, кажется, "открыть" не по умолчанию двойным кликом на внешние диски...

Обновление: похоже, что есть пара ошибок, которые могут быть связаны:

+888
Susie Queue 5 мая 2015 г., 5:00:59

Как конвертировать WAV в OGG и MP3 с VBR и отличное качество?

Если это возможно, используя soundconverter выступает или через FFmpeg.

Я, кстати, пытался ли soundconverter выступает использует VBR и нет ничего об этом в GUI настройки, так и не понятно. Не так ли?

+878
Albert Lindsey 23 июл. 2015 г., 21:40:55

Я пытаюсь установить Ubuntu 12.10 с VirtualBox. Я позволил 20Gb места на виртуальный компьютер и когда я попытался установить его, он сказал, что у меня нет достаточно места, которых у меня более 100 ГБ. И я действительно не хочу, чтобы отформатировать жесткий диск, потому что это испортит все. Как я могу это исправить?

+874
Silton 11 нояб. 2014 г., 7:03:35

Я вижу вы используете /tmp/ и для MySQL.гнезда, так как вы не устанавливаете с MySQL 5.1, которая поставляется с Ubuntu по умолчанию или вы установке MySQL 5.5.х (которые нужно упомянуть в ваш вопрос, если это так). В любом случае некоторые вещи вы можете сделать:

  1. Убедитесь, что MySQL не запущен: ПС-е|грэп -я 'проще' , если он появится, то убьет его. судо killall -9 mysqld в . Если он не умирает захватить пид от ПС вы сделали здесь и убийство -9 PID

  2. "Попробовать" запустить MySQL через файл/etc/инит.д/MySQL можно начать , если он дает вам точно такую же ошибку, как вам нужно скопировать в MySQL.сервер файл из MySQL, который вы загрузили, который может быть найден в поддержку-файлы папку в MySQL в папке, которую вы скачали, или в /usr/местные/MySQL в папку и скопируйте его в/etc/инит.д/с MySQL (пример: хп в MySQL.сервера в /etc/инит.Д/в MySQL и дать ему разрешение исполняемым командой chmod +х /етц/инит.д/MySQL и затем запустить его снова.

  3. Если он все еще дает вам проблемы, то отредактируйте файл config в файле/etc/мой.КНФ (если у вас установлен 5.5) или в/etc/mysql в/в MySQL.конф (если у вас есть 5.1 установлен) и изменить все в /tmp/и в MySQL.гнездо строк в файле/var/выполнения/которых mysqld/mysqld в.носок. Обратите внимание, что конфигурационный файл можно в файл/etc/mysql в/мой.КНФ.

    Проверить это, но, пожалуйста, добавить, что MySQL вы используете, либо 5.1 или 5.5. Я упоминаю здесь потому, что 5.5 5.5-это тот, который использует /tmp и 5.1 использует по умолчанию /var/запуск

Если по каким-либо изменить вам случится быть с помощью 5.5, то не забудьте удалить папки старой 5.1 в /etc/mysql в файле /var/библиотека/MySQL и /пользователь/библиотека/MySQL в

+830
Adam Hicks 4 нояб. 2013 г., 15:38:11

Я переустановил Ubuntu и я сейчас не могу изменить/вход мое настоящее имя. Memenu не отображает ссылку либо. Есть ли способ, чтобы ввести эти данные вручную, путем изменения некоторых скрытых файлов или что-то?! Окно, кстати, пользователь-менеджер тормоза при попытке сменить аватар... enter image description here

+662
tornadoboy 10 авг. 2015 г., 3:27:47

С помощью SystemRescueCD (на компакт-диск, а не USB), переформатирования раздела, и снова используя LiveCD с Убунту работал нормально.

+628
tedward23 5 мар. 2017 г., 0:12:36

Я только что установил Ubuntu 11.10 на новейшие разработки. Все шло, как ожидалось. Тогда я попытался применить 260 странным обновления он нужен, как обычно. Что тогда я получаю сообщение об источниках подлинности не правильно.

Как я могу исправить это?

+585
Ghader Farhody 8 апр. 2019 г., 6:19:24

ваша оболочка-это исполняемый файл, вы можете позвонить. Так что если вы используете bash, вы можете позвонить Баш и если вы используете что-то другое, как ЗШ вы можете просто ввести ЗШ

+540
Longpoke 28 июл. 2011 г., 20:11:39

Как я могу закрыть все открытые окна Наутилус одним махом? Я использую 10.10 и 10.04. Я возьму что-нибудь комбинации клавиш, команды командной строки, или действий мыши.

+523
aldodelgado 10 дек. 2011 г., 23:47:39

Webmin является лишь веб-интерфейс к различным службам и приложениям на Ubuntu, если у вас есть почтовый транспортный агент (МТА), с sendmail установлен и хотите удалить его, а затем использовать apt-получить удалить sendmail или APT-получить продувки sendmail в команду, как обычно, или использовать менеджер пакетов Synaptic, если вы имеете в виду удаление через Webmin с интерфейсом, то вы можете использовать командную оболочку, расширяя другие пункт в левой панели и выбрав команду оболочки пункт запустите apt-получить команду на соответствующую страницу. Возможно, вам придется использовать ... да выключателя при выполнении команд оттуда, не рекомендуется вообще, лучше всего было бы использовать SSH для этого, по SSH интерфейс доступен в Webmin, но он не работает иногда.

Если вы просто хотите удалить модуль sendmail в Webmin, которая взаимодействует с sendmail в МТА, то, выполнив следующие действия могут помочь:

На боковой панели щелкните в Webmin, когда элементы разверните нажмите в Webmin конфигурации, в окне по правой кнопке в Webmin модулей, на открывшейся странице щелкните удалить закладку в удалить модули списке выберите нужный модуль, а затем нажмите Удалить выбранные модули, кнопки, вы можете нажать кнопку Обновить модули элемента в нижней части левой панели.

Некоторые люди рекомендуют кожа eBox (доступен в репозитории) в качестве замены для Webmin, я не знаю, насколько хорошо это будет работать, поскольку я никогда не использовал его.

кожа eBox с тех пор стали Zentyal здесь; http://www.zentyal.org/ руководства по установке находится здесь; http://trac.zentyal.org/wiki/Document/Documentation/InstallationGuide

+506
brimat 10 июн. 2019 г., 20:50:06

Возможные Дубликаты:
Как я могу настроить беспарольный вход по SSH?

Я пытаюсь подключиться к SSH с помощью следующей команды:

СШ user:[email protected]

но он просит пароль, как я могу войти без снова просит пароль?

+470
Someone Else 4 июн. 2015 г., 7:45:35

Вариант 1

Если у вас есть дополнения установлены и могут использовать от ДД строке поиска:

судо команду gedit /usr/lib/firefox/distribution/searchplugins/locale/en-US/duckduckgo.xml

и следовать линии в нижней части других параметров это:

<Парам имя="гл" значение="де"/>

Сохраните и закройте, перезагрузите Firefox и попробовать поиск.

Вариант 2

Установить добавить в поисковую строку аддон и перезапустите Firefox:

Добавьте в строке поиска

Посетить домашнюю страницу ДД, щелкните правой кнопкой мыши на строке поиска и нажмите кнопку "Добавить в панель поиска"

В поле ключевых слов введите "гл=де"

Сохранить и перезапустить Firefox.

Убедитесь, что поиск вы только что добавили выбран (там может быть дубликат, но это может быть отсортированы по "Управление поиск

+457
stalker1997 2 мая 2010 г., 16:17:52

Я в состоянии установить связь с другим ноутбука (вин 7) и даже умеет отправлять файлы (на удивление около 3-4 Мбит / с). Но я не смогла найти, где именно эти файлы сохраняются в моей Убунту 12.04. Есть в любом случае, где я могу установить папки по умолчанию для него.

+404
pupeno 23 июл. 2013 г., 6:07:17

Существует обширный список зеркал, в том числе, как вверх-к-Дата они, здесь. Если вы нажмете на зеркало, это даст вам URL-адрес для использования в источниках программного обеспечения (или источник.список).

Для образов дисков зеркала, см. здесь.

+399
Dheeraj Singh 20 дек. 2017 г., 12:48:07

Иногда gconf редактор откроет дополнительные возможности. В этом случае, нет ничего соответствующего В разделе "приложения" / "Наутилус".

Этот вопрос был запрос на Launchpad пару лет назад : https://answers.launchpad.net/ubuntu/+вопрос/48705, но ошибки не было подано позднее.

Ваша единственная опция, чтобы вручную выровнять иконки.

+366
Francyne Doyle 29 дек. 2010 г., 5:23:23

Я тоже с помощью HP павильон Г6-1302tx, я следовал следующей ссылке для установки графических драйверов на мой ноутбук.

http://www.upubuntu.com/2012/03/how-to-install-ati-amd-catalyst-122.html

Пустой экран при загрузке времени все еще вопрос. Ну параметр nomodeset резко увеличивала яркость экрана и клавиши регулировки яркости перестали отвечать; поэтому лучше не использовать опцию nomodeset.

Надеюсь, что это полезно.

+329
valeryz 27 июл. 2017 г., 22:07:17

О чем ты думаешь-это наверное супер+Вт.

+296
savela666 18 апр. 2013 г., 23:38:47

Звучит как видеодрайверы для меня.

Может, попробовать в командной строке установки , а затем добавить панель на ваш выбор после как Xfce?

+270
ZoomVirus 22 июл. 2015 г., 13:33:31

Вы не можете изменить окружающую среду разных процесса, как в GNOME-сессии, вы можете только изменить переменные окружения текущего процесса и последующего ребенка автоматически.

Итак, вы ограничены запускать каждый процесс из терминала, где вас источником новых условиях, чтобы извлечь выгоду из изменений.

+236
Arikulu 4 июн. 2016 г., 6:27:11

Я попробовал загрузиться с DVD-диска для установки Windows 8, но, к сожалению, я могу только установить Windows 8 на жесткий диск с файловой системой NTFS. Так я запустил GParted, но я не могу создать новый раздел. Я думал, я мог бы подключить жесткий диск к другому компьютеру у меня. В нем есть е-Сата разъем, так что я не уверен, если он будет работать. Даже тогда, смогу ли я его отформатировать и установить Windows 8 на нем?

Все это просто идеи у меня были, что либо не работает, или я боюсь, чтобы проверить. Что я могу сделать, чтобы установить Windows 8 на компьютер, который не отформатирован в NTFS.

+231
Anterrio Niles 25 янв. 2019 г., 16:00:28
  1. Начать интерфейсом dconf-редактор
  2. Перейдите к орг -> препроцессор -> настройки-демон -> Плагины -> власть
  3. Изменение значения процент-критические и процентных действий до уровня требуется
  4. Изменение -время-для-указание на ложные
  5. Молодец!

Вы также можете сделать это из терминала с:

gsettings установленные org.гном.настройки-демон.Плагины.процент-критическая мощность 10
gsettings установленные org.гном.настройки-демон.Плагины.процент-действия власти 9
gsettings установленные org.гном.настройки-демон.Плагины.используйте-времени-для-политика власть ложного
+208
Bastian Nanchen 6 янв. 2014 г., 1:26:18

У меня есть карта Nvidia GTX 570 в моей машине, с двумя мониторами. Это очень, очень почти работает. Я использую Кубунту 12.10. После установки обоих мониторах работал отлично, мне только пришлось поменять их порядок (моя главная на право, он предположил слева) и я был в состоянии сделать это с Убунту дисплей менеджер.

Затем я позволила драйверов NVIDIA. Они работали прямо с места в карьер! Кроме того, они предположили, неправильный физический порядок моих дисплеях. Итак, я зашел в настройки Nvidia приложение, чтобы изменить это. Дела пошли под гору быстро. Теперь, даже с драйверами NVIDIA после перезагрузки, оба монитора были работать правильно во всех отношениях, кроме своего заказа. И в приложении настройки Nvidia, под GPU 0 товар он признает обоих мониторах, и она признает их правильное разрешение (1920х1200 например, 1680х1050 для других). Однако, когда я захожу на сервер X элемент конфигурации дисплея, он отображает оба монитора с разрешением 1024х768, встроенные в их нужного размера. Я могу выбрать только 1024х768, а максимальное разрешение либо монитор. Я могу перетащить их в коробки и установить их должным образом физически, но если я применяю эти настройки, даже с автоматическим, выбранные для их разрешения, она меняет обоих мониторах 1024х768.

Мое лучшее предположение относительно того, почему это происходит потому, что до 1920x1200 монитор работает на 75Гц, а 1680х1050 монитор работает на 60Гц, хотя он может сделать 75 Гц при более низких разрешениях. Я могу только догадываться, что 1024х768-это самое высокое разрешение, которое позволяет им работать с той же скоростью обновления (хотя до 1920x1200 легко работать при 60 Гц, а также, и это, кажется, делает это прямо сейчас).

Я пытался исследовать эту проблему, но я не нашел никого с такой проблемой, когда приложение настройки Nvidia явно прекрасно распознает и отслеживает, он просто отказывается разрешать установку резолюций, он уже запущен мониторинг по. Я хочу создать пользовательский файл xorg.conf, если я должен, но я найти некоторые инструкции, рекомендации включение с xinerama, других лиц, выступающих компании "твинвью", и никто адекватно объяснять назначение различных линий (например, я не знаю, если я должен использовать 'metamode' или как зделать если надо).

Любая помощь будет высоко оценили. Я просто хочу, чтобы драйвер для NVIDIA делать то, что он сейчас делает (хотя натыкаясь моих больших мониторов к своей родной 75 Гц не так уж и страшно), за исключением позвольте мне переместить мышь с одного экрана на другой, без того, чтобы обернуть вокруг в противоположную сторону, как мониторы выложил!

+156
cavpollo 10 июн. 2019 г., 9:51:34

Нашел виновника, это драйвер Nouveau. После установки проприетарного драйвера Nvidia у меня больше нет отставания окна. Так что есть решение для этой проблемы. Я бы предпочел, используя драйвер с открытым исходным кодом в стиле модерн, хотя так я собираюсь попробовать и выяснить, почему модерн является причиной этих окон не отвечает. С тех пор как я нашел причину моей проблемы, я считаю этот вопрос ответил.

+137
Mike Muccia 23 июл. 2014 г., 9:25:51

В оба установлены, Вы можете установить Ubuntu-классических для GNOME, основанный на Ubuntu, и Kubuntu-Desktop для Кубунту.

Если у вас есть и установлен, вы можете настроить диспетчер по умолчанию с

судо команды dpkg-перенастроить использовать GDM (или KDM)

В любом случае вы можете выбрать, следует ли использовать Gnome или KDE на экране входа.

Чтобы удалить, вы можете удалить Ubuntu-Desktop или Kubuntu у стола, затем запустить

судо apt-получить autoremove

В зависимости от дополнительных пакетов установлен, какими-то обрывками пакетов может остаться.

Если у вас есть отдельный домашний раздел, вы можете просто переустановить Убунту/Кубунту, форматирование корневого раздела, не касаясь ничего в свой домашний раздел. Это даст вам чистую установку, за исключением некоторых конфигурационных файлов, остающихся в свой домашний раздел. Конечно, все-таки убедитесь, что у вас есть резервная копия ваших важных данных.

+25
user150747 18 апр. 2019 г., 13:09:55

Показать вопросы с тегом